Mis problemas en WP 2.5

Como todas las versiones de WordPress o incluso se podría decir, como todas las versiones de todos los programas, las nuevas versiones, además de corregir errores y traer nuevas funcionalidades también traen errores. Puesto que acabo de actualizar mi versión de WordPress a la 2.5, todavía no habré encontrado todos los errores que me afectan, pero ahí va la lista por si a alguien le pasa lo mismo:

  • Si tienes activada la opción de generar los feeds completos, los feeds aparecerán completos, incluso si en el post añades el tag ‘|more’, esto no pasaba en versiones anteriores. En el trac de wordpress señalan que esto se ha hecho así a propósito para ajustarse mejor a la opción pero si prefieres la forma de funcionar anterior Dogguie, en el foro de ayudawordpress, ha dado con una solución para que vuelva a funcionar como en la versión anterior. En mi opinión deberían ser dos opciones distintas para el tag more: cortar en el feed (si/no) y cortar en el home (si/no).
  • El plugin wordpress.com stats me funciona “a medias”. Me muestra el gráfico bien y el número de visitas a los artículos también pero no muestra, por ejemplo, los títulos de los post. También en el foro de ayuda wordpress me dicen que al resto no les pasa, así que puede que sea problema de mi instalación.
  • El widget de enlaces no devuelve código XHTML válido. Este error parece que se arrastra desde versiones anteriores, en el trac he encontrado que para solucionarlo hay que añadir, dentro de includes/widget.php, antes de la llamada a wp_list_bookmarks() en wp_widget_links(): $before_widget = preg_replace('/id="[^"]*"/','id="%id"', $before_widget);
  • El plugin wordpress mobile edition ha dejado de funcionar. Sospecho que se trata de un problema de compatibilidad con los plugins de caché (en mi caso wp-cache), así que le dejaré desactivado hasta que consiga resolverlo.

Y aunque no es achacable a WP 2.5, durante la actualización, en la que he intentado utilizar el plugin wordpress automattic upgrade (que me había funcionado bien en la copia local), he tenido problemas con los permisos de escritura, lo que me ha hecho tener que instalar la versión de WP a la antigua usanza sin usar el plugin. Parece que el plugin está “pensado” para una configuración de permisos más laxa que la tengo yo en el hosting.

Otro problema con el que he perdido tiempo ha sido que la función get_avatar que proporciona wordpress desde esta versión 2.5, no he conseguido que admita, en la URL de la imagen por defecto, funciones php (para coger el path hasta el theme) y al final la he tenido que dejar con la URL completa (bueno, admitirlas si las admitía pero luego no encontraba la imagen). Pero sobre este punto no descartéis que se deba a mi “pardillez” en el manejo del php.

Bueno, espero que si a alguien le pasa lo mismo le sirvan estos consejillos

Anuncios

Un comentario en “Mis problemas en WP 2.5

  1. Sobre las URL en la función get_avatar, pasa lo mismo que pasaba con el plugin gravatar, o al menos a mi me pasaba, así que o no se debe a tu “pardillez” o se debe a la de los dos, jeje.

    Y sobre los plugins, es sorprendente la cantidad de código que meten y que no devuelve XHTML válido. 😦

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s